Рейтинг@Mail.ru
Определённый интеграл в Excel
Определённый интеграл в Excel

Как в Excel вычислить определённый интеграл

Давайте разберёмся, как вычислить определённый интеграл таблично заданной функции с помощью программы Excel из состава Microsoft Office.

Инструкция по нахождению определённого интеграла в программе Microsoft Excel

1Постановкафизической задачи

Допустим, у нас есть таблично заданная некоторая величина. Для примера пусть это будет накопленная доза радиации при авиаперелёте. Скажем, был такой эксперимент: человек с дозиметром летел на самолёте из пункта А в пункт Б и периодически измерял дозиметром мощность дозы (единицы измерений – микрозиверт в час, мкЗв/ч). Возможно, Вас это удивит, но при обычном перелёте на самолёте человек попадает под радиоактивное излучение, превышающее фоновый уровень до 10 раз и даже больше. Но воздействие это кратковременное, и поэтому не столь опасное. По результатам измерений у нас есть таблица вот такого формата: Время – Мощность дозы.

Таблично заданная величина
Таблично заданная величина

2Геометрический смыслопределённого интеграла

Как мы помним из курса школьной алгебры, определённый интеграл – это площадь под графиком нужной нам величины. В нашем примере, чтобы найти накопленную дозу радиации, нужно определить площадь фигуры под графиком таблично заданной мощности дозы. Накопленная доза радиации равна площади фигуры под графиком мощности дозы

График изменения мощности дозы во время полёта
График изменения мощности дозы во время полёта

3Методика вычисленияопределённого интеграла

Вычислять интеграл мы будем самым простым, но довольно точным методом – методом трапеций. Напомню, площадь фигуры под графиком любой кривой можно разделить на прямоугольные трапеции. Сумма площадей этих трапеций и будет искомым значением определённого интеграла.

Площадь трапеции определяется как полусумма оснований, умноженная на высоту: S = (A + B) / 2 × h Основания в нашем случае – это табличные измеренные значения мощности дозы за 2 последовательных промежутка времени, а высота – это разница времени между двумя измерениями.

Метод трапеций для вычисления значения определённого интеграла
Метод трапеций для вычисления значения определённого интеграла

4Согласованиеединиц измерения

В нашем примере измерения мощности дозы радиации даётся в мкЗв/час, а шкала времени – с точностью до минут. Мы не можем брать интеграл по времени, измеряемому в минутах, для величины, измеряемой в часах.

Поэтому необходимо перевести мкЗв/час в мкЗв/мин.

Для перевода просто разделим мощность дозы в мкЗв/час построчно на количество минут в часе, т.е. на 60. Добавим ещё один столбец в нашу таблицу. На иллюстрации это столбец "D". В столбце "D" в строке 2 вписываем =С2/60 А потом с помощью маркера заполнения распространяем эту формулу на все остальные ячейки в столбце "D", (т.е. тянем мышью чёрный прямоугольник в правом нижнем углу ячейки). Таким образом, в столбце "D" у нас появятся значения мощности дозы радиации, измеряемые в микрозивертах в минуту для каждой минуты перелёта.

Согласуем единицы измерения по шкале времени и шкале мощности дозы
Согласуем единицы измерения по шкале времени и шкале мощности дозы

5Вычисление площадей отдельных трапеций

Теперь нужно найти площади трапеций за каждый промежуток времени. В столбце "E" будем вычислять по приведённой выше формуле площади трапеций. Полусумма оснований – это половина суммы двух последовательных мощностей дозы из столбца "D". Так как данные идут с периодом 1 раз в минуту, а мы берём интеграл по времени, выраженному в минутах, то высота каждой трапеции будет равна единице (разница времени между каждыми двумя последовательными измерениями, например, 17ч31мин — 17ч30мин = 0ч1мин = 1мин).

Получаем формулу в ячейке "E3": =1/2*(D3+D2)*1. Понятно, что "×1" в этой формуле можно не писать. И аналогично, с помощью маркера заполнения, распространяем формулу на весь столбец. Теперь в каждой ячейке столбца "Е" посчитана накопленная доза за 1 минуту полёта.

Вычисление площадей прямоугольных трапеций за каждый промежуток времени
Вычисление площадей прямоугольных трапеций за каждый промежуток времени

Если бы данные шли не через 1 минуту, то нам нужно было бы написать формулу так:
=1/2*(D3+D2)*(МИНУТЫ(A3) – МИНУТЫ(A2)).
Правда при этом, если есть переход на следующий час, то получится отрицательное значение. Чтобы этого не произошло, впишем в формулу часы:
=1/2*(D3+D2)*(ЧАС(A3)*60+МИНУТЫ(A3)) – (ЧАС(A2)*60+МИНУТЫ(A2)).
Если переходим на следующие сутки, то нужно будет уже добавлять даты, и т.д.

5Определение площадипод графиком функции

Осталось найти сумму вычисленных площадей трапеций. Можно в ячейке "F2" написать формулу: =СУММ(E:E) Это и будет сумма всех значений в столбце "E", т.е. численное значение искомого определённого интеграла.

Но давайте сделаем вот что: определим накопленную дозу в разные моменты полёта. Для этого в ячейку "F4" впишем формулу =СУММ(E$3:E4) и маркером заполнения распространим на весь столбец "F".

Обозначение E$3 говорит программе Excel, что увеличивать индекс ячейки "3" в столбце "E" при переносе формулы на следующие строки не нужно. Т.е. в строке 4 формула будет определять сумму в ячейках с "Е3" по "Е4", в строке 5 – сумму с "Е3" по "Е5", в строке 6 – с "Е3" по "Е6" и т.д.

Построим график по столбцам "F" и "A". Это график изменения накопленной дозы радиации во времени. Наглядно видно монотонное увеличение накопленной дозы радиации за время полёта. Это говорит о том, что мы правильно рассчитали интеграл. И окончательное значение накопленной за двухчасовой полёт дозы радиации, которое получается в последней ячейке этого столбца, равно примерно 4,5 микрозиверт.

Вычисление суммарной площади всех трапеций, что численно равно искомому определённому интегралу
Вычисление суммарной площади всех трапеций, что численно равно искомому определённому интегралу

Таким образом, мы только что нашли определённый интеграл таблично заданной функции в программе Excel на реальном физическом примере. В качестве приложения к статье – файл Excel с нашим примером.

Скачать вложения:

Последнее изменениеВторник, 15 Декабрь 2015 11:37
(5 голосов)
Прочитано 4707 раз

Поделиться

Оставить комментарий

Убедитесь, что вы вводите (*) необходимую информацию, где нужно
HTML-коды запрещены